Wave Music Home
ReleasesCommunityYour OrderWave Music
ArtistsEventsDJ MixesShop

Wave Music Home


Home
About Us
Labels
Distributed Labels
Links




Search


Adv. Search



Subscribe


Email






Go Back   Wave Music Community Board > Tech Talk for Gearheads

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-01-2006, 06:17 AM
flightparties flightparties is offline
Registered User
 
Join Date: Jan 2006
Location: Palma de Mallorca
Posts: 42
Unhappy Help with my Crest Audio P.A

Hi friends

My old school Crest Audio Power amplifier Power series Model 300 has channel A allways cliping even with a low input signal. Any Idea or web to download troubleshooting guides or schematics?

Thanks in advance:
__________________
www.flightparties.com
Best aeronautical parties with soulful house music
Reply With Quote
  #2  
Old 02-01-2006, 01:12 PM
louped garou's Avatar
louped garou louped garou is offline
Registered User
 
Join Date: Feb 2004
Location: left the building
Posts: 640
schematic here

http://www.musicparts.com/products.asp?Company=Crest

not my site, but they have the schematic here...
__________________
____________________________________
dormant account,
please see later iterations of me...


dsa_audio or Mistick Krewe or dave
Reply With Quote
  #3  
Old 02-01-2006, 03:05 PM
flightparties flightparties is offline
Registered User
 
Join Date: Jan 2006
Location: Palma de Mallorca
Posts: 42
Thank you for share this info

some pics of the patient
















Thanks for all Channel A (Faulty) Itīs with a red sticker
__________________
www.flightparties.com
Best aeronautical parties with soulful house music
Reply With Quote
  #4  
Old 02-01-2006, 03:50 PM
louped garou's Avatar
louped garou louped garou is offline
Registered User
 
Join Date: Feb 2004
Location: left the building
Posts: 640
http://www.crestaudio.com/service/

You may have seen this already, but maybe you can call crest directly to get the password for the schematic section of their service website......
__________________
____________________________________
dormant account,
please see later iterations of me...


dsa_audio or Mistick Krewe or dave
Reply With Quote
  #5  
Old 02-02-2006, 06:09 AM
flightparties flightparties is offline
Registered User
 
Join Date: Jan 2006
Location: Palma de Mallorca
Posts: 42
Talking PROBLEM SOLVED !!!!!!

Hi thank you very much Louped Garou for your help, After a long, long night I solved problem, I found 6 bad solder points and after resolder and hard testing with 8 Ohm Charges at full power, I can say everything is OK
Now Itīs time to sleep

Thank you very much Louped for your support again
__________________
www.flightparties.com
Best aeronautical parties with soulful house music
Reply With Quote
  #6  
Old 02-04-2006, 01:03 PM
animal animal is offline
Registered User
 
Join Date: Sep 2005
Posts: 108
Smile

Thats good that it was a pretty easy fix. I was never a big fan of the older crest amps but that was just ignorance on my part. Just took a look at the new stuff. The specs are awsome. Have you worked with any of the new crest line? Just wondering.

animal
Reply With Quote
  #7  
Old 02-05-2006, 08:17 AM
flightparties flightparties is offline
Registered User
 
Join Date: Jan 2006
Location: Palma de Mallorca
Posts: 42
I just worked with older Power in line series (pictures) and with 3001 and 5001 series, I also worked with Carver very good relation between Wats:Weight
__________________
www.flightparties.com
Best aeronautical parties with soulful house music
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:35 AM.


Powered by vBulletin Version 3.0.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Đ2006 Wave Music


© Wave Entertainment Group, Inc.