Wave Music Home
ReleasesCommunityYour OrderWave Music
ArtistsEventsDJ MixesShop

Wave Music Home

About Us
Distributed Labels


Adv. Search



Go Back   Wave Music Community Board > Tech Talk for Gearheads

Thread Tools Search this Thread Rate Thread Display Modes
Old 07-15-2013, 04:43 PM
jambourgie jambourgie is offline
Registered User
Join Date: Mar 2009
Posts: 17
Strange Amplifier problem.

Hi there,

I've been having an intermittent problem with my amplifier. It sometimes cuts out on the left side. The strange thing is, If I give the volume a good quick boost, it comes back on for a while. Almost like the high volume forces its way through.

Any ideas? I'm not a complete stranger to the soldering iron

Reply With Quote
Old 07-15-2013, 07:49 PM
DSA.audio's Avatar
DSA.audio DSA.audio is offline
Registered User
Join Date: Feb 2006
Location: hoodoo audio heaven
Posts: 1,337
it's possible that some contacts or switches are dirty...

the Mistick Krewe account is temp. disabled,

forgive the ressurection of DSA.audio please...
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:32 PM.

Powered by vBulletin Version 3.0.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
2006 Wave Music

© Wave Entertainment Group, Inc.